Dissapointing dyno result – Solved..!

This few days, I can not sleep and eat.. I wish I did not do the Dyno.. :). But that is the beauty of having old car, this problem is actually a lot more interesting than problem in the office, you do not know what is wrong… it just does not work as expected but the good thing is almost everything under our control to solve it…

Image

Dolly at Dyno machine

So what is wrong then… if you read my previous post, you know that Dolly power is low, and peaked at 3000RPM, which should be around 4500 RPM and  lot higher.  A lot of things can be the cause, I need to check it one by one…

  1. Engine Compression, may be the compression is low and resulting low HP… checked… and the result is 165 psi across all pots. so no problem here.
  2. Fuel supply problem… how can it be..? I just replace the seal… and seems works ok
  3. What about ignition timing..? I checked using strobe and the result is 5 deg, should be no problem…
  4. The suspect  now is the carburetor SU HS6 or electronic Ignition or problem with the timing chain

The fellow land rover forum said that the Electronic Ignition can be faulty, or since I do not know the advance curve of this distributor, it may be not suitable for landrover… to prove this point, I did an exercise… set the ignition timing too advance (deliberately) and drive it full power (stopped when it start knocking), and then retard it a bit and drive it full power again, and so on and so forth until the timing is too retarded  loss power at all RPM). In this exercise, I found that no matter what, I lost power after around 3000 RPM at all ignition timing set up. So the Electronic ignition is no longer suspect.

Now how about carburetor, again little exercise in the morning, I set the jetting from too rich to too lean, again the result is the same.. loss power at around 3000 RPM. and I gave up… I am not bother checking the timing chain, the symptom is not relevant for timing chain. I just use it at low rpm, but back in my mind I always have that question… “what the hell is wrong”  something is fundamentally wrong and we can not find out what it is..? even my fellow land rover forum who usually very knowledgeable on this matter can not solve this riddle.

Finally I went to local Land rover garage and discuss it with the garage owner, I show the dyno result… just with one glance he said… ” Fuel supply problem..!”. Can not be… I replaced the seal and clean it… “Fuel supply problem..!” he said again… How can it be..? I challenge him… “FUEL SUPPLY PROBLEM.. ! DAMNED..!” he almost throw the “land rover number one tool” at me.

Ok Ok.. I said… how to solve it…? He then installed an electronic fuel pump after the mechanical lift pump… “this will do” he said. “let me know how it goes…” Why not install it before the mechanical pump..? me questioning his installation… “you fool..! you want the fuel flood your engine and blow you up…?” and it shut me down… :) here is the installation..

1-IMG-20130613-00963

Very true.. this solve the problem… I can feel Dolly is still pulling even after 3000 RPM, very happy, I say thank you to him (and pay of course) and drove home smiling… I do not bother to dyno it again… one because I have to pay, two I am afraid that I will find another problem that keep me awake during the night… may be later, but not now :)

So moral of the story is… don’t dyno even if it is free…. ah ha ha..

Advertisements

One thought on “Dissapointing dyno result – Solved..!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s